Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26

Thread: Outpost 7.5 Auto-Learn Blocking Java 7 HTTP

  1. #16
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    I've tried allowing all network activity for most of my applications. I even tried creating rules from the process activity page, allowing all network activity. Try creating a low-level system rule to allow all http-out, but I have a feeling that even that is not going to work. Of course, I don't want you to keep that rule if it does work. It's only a test. I don't have Outpost installed at this time to try it myself. I'm sure that you already have a rule for javaw.

  2. #17
    Join Date
    Jan 2012
    Posts
    36

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    Maybe Outpost is blocking it as Active Content? Try going to "Blocked Content" in the logs on the left (clicking "Switch to Expert Mode" if needed), and at the right top specify Active Elements. Do you see anything there?

  3. #18
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    Note that I am not having a problem when using Privoxy. Outpost does filter content even when using a proxy server. I did try disabling content filtering for javaw, but your suggestion has given me an idea to try disabling web filtering inside the machine.ini file, so thanks for the suggestion.

  4. #19
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    I don't have Java 7 installed at this time, but I found another program that's displaying the same behavior - TRUEIMAGEHOMENOTIFY, which is a part of Acronis True Image. If you are not using IPv6, try this:
    settings,network rules, System-Wide rules, Low-Level Rules
    double-click "Allow IPv6 Hop-by-Hop Option", change "allow" to "block"
    Last edited by romil; 02-04-2012 at 19:22.

  5. #20
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,849

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    user of java 7 should be aware that it is NOT the java recommended version. java 7 is at this time for developers only to get a jump on future java releases, and it still has bugs. java 6 build 30 is the current end user release and i gather works with outpost. at least it works for me. so, the answer is likely that you should revert to the approved java 6 build 30.

    it's a bit like someone saying OP doesn't work with windows, then later telling us you are running windows 8.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  6. #21
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    I was using Java 7 because Marcos mentioned it. I haven't tried Java 6 yet because I don't know what version Toaster is using. This problem might not have anything to do with Java 7, and I'm probably not going find the answer for myself today because I have now entered the Twilight Zone. I don't have any version of Java on my machine. Last night, when I changed the system rule back to allow, my problem with Acronis did not return. I tried restarting and powering down my machine, and still no problem. Also last night, I was not having any IGMP messages in my firewall or packet logs. This morning, I got IGMP messages in the packet log, and after changing the system IGMP rule to allow, I have messages in the firewall log. My router is set to reboot every morning at 5 AM in order to obtain a new IP address. I tried powering down my modem and unplugging the cable from my computer to the router, and it looks like the IGMP messages are here to stay. So I am trying to figure out if I am having a system problem or not. I could try restoring my backup and starting all over again, but when I think of the work in store for me today, I am rapidly losing my energy and desire to continue testing.

  7. #22
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    Maybe I should expand on why I think TrueImageHomeNotifier(TIHN) is displaying the same behavior as Java 7. At it's default settings, the firewall log shows a TCPv6 connection to localhost for TIHN, which is successful, so it doesn't try to make a TCPv4 connection. As mentioned earlier, it looks like javaw can make a TCPv6, but since I'm not ready for IPv6, javaw will try to make a TCPv4 connection. When I configure Acronis to send me an email, I get the OUTBOUND TCPv4 packet to closed port messages that I got with Java 7. It's a different port, so web control is now out of the picture. I did not install Java Quick Starter, so if others are seeing INBOUND packet to close port messages, then restart the service. Outpost will ask to create the rule, and that problem should be solved.
    My suggestion in message #19 cleared up my Acronis problem. I have all auto-learning options turned off, so no new rule was created. Maybe Java 7 has more problems that I don't know about yet, but this thread is about the packet to closed port messages, which I think is an IPv6 Outpost problem.

  8. #23
    Join Date
    Feb 2009
    Posts
    14

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    Well it definitely doesn't work on Java 7. However when I upgraded to java 7 I also upgraded to Outpost 7.5.
    If I have time I will isolate the code and compile on java 6.

  9. #24
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    While searching for java problems, I found references about preferring IPv6 connections, but since I'm not a java programmer, I don't know where to find that preference. I searched the registry and some java files. Is that preference in the program code? If you're also not IPv6 ready, and you talked about compiling your code, I thought that this preference might be of some help to you.
    java.net.preferIPv6Addresses

  10. #25
    Join Date
    Jun 2003
    Location
    NJ
    Posts
    375

    Re: Outpost 7.5 Auto-Learn Blocking Java HTTP

    The default is false, but maybe in Java 7, the default may be true.

  11. #26
    Join Date
    Feb 2009
    Posts
    14

    Re: Outpost 7.5 Auto-Learn Blocking Java 7 HTTP

    I created some test code to reproduce the problem and the root is a conflict with Java 7.
    I have already sent the code to support.

    In short, no java 7 application is able to connect to the network with outpost running unless the policy is 'allow most'.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Auto-learn mode
    By KenW in forum Outpost Pro SECURITY SUITE General Discussions, Support, and Troubleshooting
    Replies: 10
    Last Post: 08-10-2011, 16:45
  2. Outpost 7.5 Beta -Auto-Learn Mode
    By Kurt W in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 70
    Last Post: 05-07-2011, 02:58
  3. How can I disable Auto Learn Mode permanently?
    By koocha in forum Outpost Pro SECURITY SUITE General Discussions, Support, and Troubleshooting
    Replies: 5
    Last Post: 04-22-2011, 03:32
  4. Auto-learn cannot be disabled in OSS 2008 v6.0.2279.251.482.298
    By pxmm in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 3
    Last Post: 02-27-2008, 17:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •