Results 1 to 15 of 15

Thread: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

  1. #1
    Join Date
    Apr 2012
    Posts
    9

    Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    First, I just want to say that after using firewalls Comodo, Bitdefender, McAfee, Norton, and Vipre, I am most satisfied with Agnitum Outpost's! In ALL ways but this one...

    First my setup: I am running a 32 bit Microsoft Vista OS. I have firewall set on Rules Wizard (for Auto-Learn Mode [which I have also tried disabling to bypass the probem]), with LAN settings all checked, Attack Detection is turned on and set to block intruder, IP Blocklist is off, the Anti-Spyware real-time protection is on, Anti-Leak is on (tried turning off and still no dice), System Guard is Enabled (also tried turning off to see if it would help), Application Guard is Enabled (also tried turning off to see if it would help),and I doubt the rest is pertinent as it doesn't really do with blocking specific ports or IP protocols, but Web Control is active.

    What I have tried to do: I tried Disabling Self-Protection, Leave Auto-Learn mode, Allow All as a settings, Suspend Protection for 5 minutes & 1 hour, Exit and shutdown service, restart computer (of course), reinstall/repair OFP, fully uninstall and clean install OFP
    And as for Application Rules; I've tried to set "Allow all activity" for the trouble program, Allow Outbound and Inbound UDP and TCP for the trouble program, Anti-Leak all "Allow" for trouble program (I would put in 127.0.0.1:6880 entry myself but I am unsure as to where I can. , tried to Block ICMP when the remote address is 127.0.0.1 for OP_MON.EXE, Block IP when the remote address is 127.0.0.1 for OP_MON.EXE (I am unsure how to go about keeping/blocking OFP from specifically listening/monitoring 127.0.0.1:[with 6880 port) [Anti-Leak is all Allow for OP_MON.EXE. I can't think of any more pertinent information or attempts I've tried, but if anyone needs more information, please inquire.

    In any case, apparently the program needs to be the only thing "listening" to port 6880. The only thing that resolves this problem is when I totally uninstall OFP (so I know it is the firewall causing it). I love this firewall/software and would rather not keep it uninstalled! What's peculiar is even when the firewall is off (from both exiting & shutting down the program as well as through task manager), it is still watching/monitoring/listening to that specific port! I even tried exitting and shutting down OFP service AND turned of it's service in the Services window/config (with only 1/4 success).

    I am extremely new to the program and these forums so I figure more/most experience ones as yourselves might have a better understanding and suggestions to what I could try/should do. Thank you in advanced!

  2. #2
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,850

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    where (what program) is the error message coming from? OPMON is the graphic user interface to outpost. 127.0.0.1 is also known as 'localhost', in effect your own pc. a number of programs may use localhost for communication internally. i know vuze (a bit torrent client) uses localhost on 6880 by default, but you can change that. i used 51590 instead myself when i tried vuze. worked fine.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  3. #3
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Quote Originally Posted by kronckew View Post
    where (what program) is the error message coming from? OPMON is the graphic user interface to outpost. 127.0.0.1 is also known as 'localhost', in effect your own pc. a number of programs may use localhost for communication internally. i know vuze (a bit torrent client) uses localhost on 6880 by default, but you can change that. i used 51590 instead myself when i tried vuze. worked fine.
    Thank you for the response...
    Yes the program I am using is Vuze, I apologize for not making that clear before. I did not know the OP_MON.EXE was just the GUI, it was the only thing in the Application Rules and/or Task Manager that I could figure was OFP.
    Where can you change Vuze to use a different localhost port? I have always my Incoming UDP and TCP listen port to in the 52000's but I still receive that error and get a NAT is Firewalled error as well as nothing connecting even though I can see the swarm. To your knowledge, is there another section in the settings that has it still listening to 6880?
    What I figure to attempt to do was to try and stop OFP listening on that one and only port (as it seems that's the only issue i'm running into with it). I think that might be the only answer unless/outside of changing Vuze's settings properly. Any help is greatly appreciated! Thank you.

  4. #4
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    After some research, I have come across some new information... (partially in thanks to kronckew informing me of the purpose of this port 6880 is)

    According to Vuze's wiki page, "6880 TCP: Vuze uses this port for internal communication. When you launch Vuze, it always checks that port for an older instance of Vuze being already active. If there is an active Vuze, then the new Vuze instance passes the possible torrent name as parameter to the old instance already running and then dies. (This happens e.g. when you click a "download torrent" link on a web page. A new second Vuze instance gets launched by the browser, but it dies after passing the argument to the old Vuze.) If there was no active old Vuze, then the new Vuze reserves that TCP port and starts "listening" there." So, essentially, Port 6880 is hardcoded into the program for it's own "internal communication."

    What I have found researching some of it's other optional syntax/command lines is this: "combine with -DMULTI_INSTANCE=true to open multiple instances of Azureus.
    Note: opening multiple instances of Azureus is generally a very bad idea, except in very special circumstances.
    The multi-instance flag can be used to disable the instance-checking if some other application is listening on port 6880 and prevents Azureus from starting. "
    This seemed to be what I was looking for. The trouble was I didn't know how to add this syntax to open with Vuze. I tried the Run command with the command line next to it, but Vuze just tried to open the file named the command line. I eventually found out how the .vmoptions worked and resolved this specific particular issue.

    So, in the end, I hope this helps anyone who comes across this problem and/or is looking into the same occurrence with them.

    Unfortunately, although the error came up about both programs listening to socket 6880, and I have since resolved that particular issue, I am still running into the same problems as previously stated. (MODS: I would like/rather to keep this further discussion in this thread as it regards the same program and/or it calls upon the line of thoughts/thinking brought to this point, but I understand if you wish to split the thread here. Futhermore, I would wish the title to be: "ERROR: socket Selector.open() ;Azureus / Java is likely being firewalled!")
    Does anyone (kronckew in particular) know where in the Outpost Firewall Pro's settings I can get it to not firewall the program's socket Selector.open()? As previously stated in the OP, I have done much/all that I could think of to not firewall Vuze... Thank you.

  5. #5
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,850

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    i stopped using vuze a while ago, so i'm not sure. i use utorrent occasionally tho it's hard to find legal torrents anymore. applications have an option in the settings for sockets:
    Capture 000.jpg

    you might try that for your vuze. note i also turn off the content filtering.

    glad you figured out your initial problem. i can't remember exactly how or if i changed it. i did have it listening on the higher ports as you noted. i do seem to recall there was another fairly well hidden setting you could get to to change the internal port, but i might be wrong.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  6. #6
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Quote Originally Posted by kronckew View Post
    i stopped using vuze a while ago, so i'm not sure. i use utorrent occasionally tho it's hard to find legal torrents anymore. applications have an option in the settings for sockets:
    Capture 000.jpg

    you might try that for your vuze. note i also turn off the content filtering.

    glad you figured out your initial problem. i can't remember exactly how or if i changed it. i did have it listening on the higher ports as you noted. i do seem to recall there was another fairly well hidden setting you could get to to change the internal port, but i might be wrong.
    Thanks for the response!
    Yeah, I had content filtering off, but what your picture helped me focus on was allowing access for the Rawsocket access! I had that on prompt as well..
    I had high hopes for that...but still having Vuze firewalled...

    I'll look into Vuze's settings for sockets (if any)...

    Unfortunately, from what I have researched...the only solution to the ERROR: socket Selector.open() problem has been to uninstall the firewall on the user's PC! After spending $45 dollars on the software and finally being satisfied by a firewall software, I really hate to have to discard it, but it looks more and more like that is the only thing left I can do! :-(

  7. #7
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,850

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    one last thing to try. op uses a config file machine.ini for it's oddball settings. it requires you to shut down and exit op before you edit the file (op overwrites it from memory on shutdown & reads it on startup). also set OP to allow changing it's files by right-clicking the tray icon & selecting 'disable self protection' from the context menu BEFORE you shut op down.

    one of the options is a variable called SkipFilterLoopbackStream which is set to false by default. the 127.0.0.1 traffic is essentially 'loopback', setting it to TRUE might enable your opmon.exe app rules to block the 6880 port. whether that will work, or if it works whether it will have side effects, i don't know. might be worth a trial.

    after the change, save file, restart OP. enable self protection from the tray icon context menu. try your app then. if no help, i'd repeat the above & reset the variable back to false.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  8. #8
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Quote Originally Posted by kronckew View Post
    one last thing to try. op uses a config file machine.ini for it's oddball settings. it requires you to shut down and exit op before you edit the file (op overwrites it from memory on shutdown & reads it on startup). also set OP to allow changing it's files by right-clicking the tray icon & selecting 'disable self protection' from the context menu BEFORE you shut op down.

    one of the options is a variable called SkipFilterLoopbackStream which is set to false by default. the 127.0.0.1 traffic is essentially 'loopback', setting it to TRUE might enable your opmon.exe app rules to block the 6880 port. whether that will work, or if it works whether it will have side effects, i don't know. might be worth a trial.

    after the change, save file, restart OP. enable self protection from the tray icon context menu. try your app then. if no help, i'd repeat the above & reset the variable back to false.
    That is a very good idea... a bit tricky and complicated, but a good idea indeed. Fortunately, I had already resolved the block on the 6880 port.
    Unfortunately, I am still having trouble with the ERROR: socket Selector.open() problem if you or anyone has any thoughts or possible solutions to it.

    But I thank and appreciate your help in all these matters anyway.

  9. #9
    Join Date
    Apr 2012
    Posts
    9

    ERROR: socket selector.open() failed 10 times, aborted Java likely being Firewalled!

    bump

    I simply wanted to try and bump this thread...

    Unfortunately, without any more help and/or solutions for this problem, I am forced and seriously considering uninstalling Outpost Firewall and getting a refund. I really hate that I love this firewall so much and dumped a good $45 into it, just to end up dismissing it.

    Again, this is for the problem: ERROR: socket selector.open() failed 10 times, aborted
    Java likely being Firewalled

    Also, I wanted to ask kronckew if it was better/appropriate if I started a new thread of the "socket selector.open()" or not?

    Thank you for any and all help.

  10. #10
    Join Date
    Nov 2001
    Location
    London, UK
    Posts
    1,604

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Java? You're not using Java 7 are you, not sure if Outpost is compatible with it yet, but it has/had some severe issues with Java 7, which it seems there is no will to address until Java 7 is the recommended end-user version.

  11. #11
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Quote Originally Posted by MTDay View Post
    Java? You're not using Java 7 are you, not sure if Outpost is compatible with it yet, but it has/had some severe issues with Java 7, which it seems there is no will to address until Java 7 is the recommended end-user version.
    VERY interesting and informative...
    I will see if running the program with Java 6 will/might do the trick...

    Thank you so very much MTDay...whether this works out or not, I can't convey how appreciative I am of your attention to this...

  12. #12
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,850

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    java 7 update 4 IS now the recommended version. i'm installing it now for testing.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  13. #13
    Join Date
    Apr 2012
    Posts
    9

    Thumbs up ERROR: socket selector.open() failed 10 times, aborted Java likely being Firewalled!

    Quote Originally Posted by MTDay View Post
    Java? You're not using Java 7 are you, not sure if Outpost is compatible with it yet, but it has/had some severe issues with Java 7, which it seems there is no will to address until Java 7 is the recommended end-user version.


    Oh My God THANK YOU MTDay!!!!!

    That was it!!! I don't think I ever would have known...but my program is working PERFECTLY again! And I don't have to dismiss this wonderful firewall and try and get a refund!!! Thank you Thank you Thank you Thank You! If there was a bow down smiley...I would have.

    ...This is the second program that has had troubles because of Java 7. The only reason why I kept it was because of PS3 Media Server...but they updated it so Java 6 isn't a requirement...

    All issues resolved....

  14. #14
    Join Date
    May 2003
    Location
    CSA Consulate,Rm.101,Glos. UK
    Posts
    5,850

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    i tried java 7 again. can't get it to work in firefox, shows a class file as missing. i went back to the java.com download site & they are back to recommending version 6 update32 and the recommendation for v7 is gone. something is rotten in denmark i did note that java7 uses tcpv6, i've got ipv6 turned off in windows & my isp and router doesn't yet support ipv6. that may have something to do with it. anyhow glad you are back up. i'm reverting back to java 6 now.
    Regards,

    CAVE CANEM
    ET SEMPER PARATUS

    Win7 x64 SP1, i7 quad core 3770k, 16GB ram, Custom build PC wi. Asus P8Z77-I MB, nVidia GTX650, Firefox 36.0a1 x64,
    Thunderbird 36.0a1 x64, IE11, Asus DSL-N55U router, Outpost Security Suite9.1 (4652.701.1951),
    in-house IT Support Dept. consisting of two Greyhounds, both of which are now very fast angels, and one Saluki Lurcher



  15. #15
    Join Date
    Apr 2012
    Posts
    9

    Re: Another program (Outpost Firewall) is already listening on socket 127.0.0.1:6880

    Quote Originally Posted by kronckew View Post
    i tried java 7 again. can't get it to work in firefox, shows a class file as missing. i went back to the java.com download site & they are back to recommending version 6 update32 and the recommendation for v7 is gone. something is rotten in denmark i did note that java7 uses tcpv6, i've got ipv6 turned off in windows & my isp and router doesn't yet support ipv6. that may have something to do with it. anyhow glad you are back up. i'm reverting back to java 6 now.
    I actually had the same thought...
    I was seeing in OFP that the program was using all ipv6 connections...So I did as you did and actually disabled/turned it off in windows and/or Network Connections properties of my LAN/Ethernet settings...still was having the same problems...

    Hopefully that "class file is missing" doesn't cause you too many problems...

    Thank you, as well, for all the help you have given as well...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Outpost Firewall and a program called Netshare
    By Qudos in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 9
    Last Post: 05-30-2009, 00:21
  2. Outpost 2.1 + Socket Proxy Client
    By zespri in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 10
    Last Post: 06-08-2004, 20:43
  3. Program ignores OutPost firewall?
    By TheSentinel in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 5
    Last Post: 12-18-2002, 11:03
  4. Announcing an Outpost Firewall Rule distribution program...
    By Peter Palm in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 12
    Last Post: 11-28-2002, 22:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •