Results 1 to 10 of 10

Thread: Audio stutter while browsing

  1. #1
    Ross Guest

    Audio stutter while browsing

    When I have Outpost running and I'm listening to music using Winamp, the sound stutters quite often. Also my mouse stops responding for up to a ssecond at the same time. It's as if a hardware interrupt is being delayed or something while Outpost checks or logs the traffic request.

    I'm running Win98 SE, AMD K6II-500, 192MB RAM, MI5VP4 motherboard (VIA chipset).

    Is that to be expected with a software firewall? Or is it just my motherboard?


  2. #2
    Join Date
    Aug 2001
    I notice that when I listen to Mel Tillus
    Sorry, I couldn't resist.

    Actually, I had the stuttering you are experiencing when I had my old sytem configuration. 600 Mhz 128 MB Ram when playing streaming audio or video. When I upgraded to a 1.8 gig 256 MB DDR Ram, I never noticed it again. I'm not saying it definately isn't Outpost, just my experience. You can check it simple enough. Just temporarily shut outpost while listenening to the music and see if it makes a difference. (obviously don't have any browser or email windows open at the time)
    Let us know what happens.
    OS: Windows 7 64 bit Outpost Firewall Pro ver. 9.3 (4934.708.2079)
    Firefox 51.0.1 Thunderbird 45.7.0
    SuperAntispyware, MS Security Essentials, AdWare Cleaner, JRT

  3. #3
    Ross Guest
    Yeah, it's definately Outpost doing it. I listen to music all the time and it only started happening when I installed it yesterday. It also stops stuttering when I close Outpost down while still browsing. It's quite bad and annoying.

    I suspect I just need a more powerful PC. Perhaps I should invest in a hardware firewall.


  4. #4
    root Guest
    Try putting Winamp in trusted applications. That way, Outpost should not be filtering it.
    I believe your problem is low memory and speed because streaming audio does take a lot of processsing and memory.
    If putting Winamp in trusted applications doesn't work then Outpost is too heavy on your resources to do that.
    A hardware firewall will do nothing to monitor outbound traffic, so that is only a partial solution for security purposes.
    Outpost version 2 seems to be lighter on resources and when it is released, maybe you can use it.
    I know money is a serious issue in most peoples lives, but the sad fact is, to take advantage of new technology, we have to keep buying up.
    We can all thank Mr Gates for that.

    While you are listening to streaming audio, I assume you are not surfing also. If not, you could temporarily shut down Outpost without much risk. I know of no exploits that can be imbedded in streaming audio.....................yet.

  5. #5
    Ross Guest
    The problem is not with streaming audio. I am simply playing mp3 files on the hard disk. The stuttering occurs while browsing the Net when Outpost is doing it's thing. As I mentioned, the mouse stops responding for short periods at the same time. In fact, the whole PC stops responding but only for a very short time when I visit a new web site, mostly.

    My system resources are at 42%.

    I think I just need a new PC.


  6. #6
    Join Date
    Aug 2001
    Sorry Ross,
    I assumed streaming. Integrated Audio on your Motherboard, right?
    You may need more RAM. Also, have you changed your virtual memory settings? ( my swapfile is on another harddrive.) Do you have enough free space on your harddrive to accomodate the swapfile? You should have at least 10% of your harddrive free plus 2 times your RAM in addition. If you are using your virtual memory you will definately have stuttering performance.

    BTW with my experience I was talking about, I was playing downloaded files not streaming them. In fact I have WMP and Realplayer in blocked apps
    OS: Windows 7 64 bit Outpost Firewall Pro ver. 9.3 (4934.708.2079)
    Firefox 51.0.1 Thunderbird 45.7.0
    SuperAntispyware, MS Security Essentials, AdWare Cleaner, JRT

  7. #7
    Join Date
    Feb 2003
    North West, United Kingdom
    Ross, what version of Winamp are you using - 2.xx or 3? 2.xx is supposed to be more efficient so trying that if you are currently running 3 may be a good idea. If Winamp Agent is running, consider disabling it. Also try changing Winamp's settings to specify that you have no Internet connection.

    Your system resources are very low - even with several utilities running you should have 70-80% free on startup. Consider disabling some of the programs that Windows is running on startup - some will be in the Startup entry of your Start Menu (under programs); others will be shown in the Startup tab when you run msconfig (clear the tickboxes to prevent them starting again on the next reboot - you will, if I recall, also need to select "Diagnostic startup").

    As Chris has said, check your swapfile settings - having a fixed size swapfile is the best (your RAM should not be a problem though, 192MB should be plenty for Win98). Defrag your hard disk to make sure that files are not scattered all over your disk (if you have not done this before, it can make a difference - but allow a few hours for it to complete - subsequent defrags will be faster).

    Consider using Wintop (downloadable as part of Microsoft's Kernel Toys collection here). Although intended for Windows 95, I have run it successfully under Windows 98 - it will list all the processes running and give CPU utilisation for each one. This will tell you if you have a CPU-hog running on your system. Another process monitor with more features is TaskInfo.

    Finally, check that you have up-to-date drivers for your soundcard and motherboard (the Via 4-in-1 driver can be downloaded here).

  8. #8
    Join Date
    Mar 2002
    Fort Worth, TX USA
    Hi Ross,

    There are a lot of good suggestions here and I only want to make three points.

    1. Paranoid's comments about msconfig (shutdown unused processes), updated drivers, and especially TaskInfo are very good ideas for you to try.

    2. Chris's idea about checking your virtual memory settings is also a good idea.

    3. If the ideas that have been presented to you above do not solve your problem, my suggestion is that if you do not need all of the plugins, shut some off. This should save some resources and reduce processing due to Outpost.

    You can do this simply by opening the Outpost GUI and from the menu choosing Options -> Plug-Ins Setup. Then, simply highlight the plugins that you do not need and click the 'STOP' button. After you are finished stopping plugins, click Apply and OK to close the options screen. I would follow this plan:

    a) Immediately stop the DNS Cache, Content, and the Attachments Filter. Reason: DNS Cache is just another record of your internet activities and I am doubtful of any noticeable per session increases in web pages because of the cache. The Content plugin is really only useful if you have children in the house. And finally, I prefer to let my Anti-Virus handle e-mail attachments so I shutdown the Attachments Filter plugin.

    b) If you are still experiencing problems after trying item a), then try stopping the Ads plugin. Actually, you can try steps b) and c) in the order that you choose.

    c) If you are still experiencing problems after trying item b), then try stopping the Attack Detection plugin.

    d) If you are still experiencing problems after trying item b), then try stopping the Active Content plugin. Shut down this one last because it is probably the most important plugin.

    e) If none of that works, then you might try reducing the loggins. Open the Outpost GUI and from the menu choose View -> Layout. Under the heading 'Left Pane', select ONLY the following logs: Established and Blocked. Those two logs are the most conservative and problem free.

    Note: Actually, you can really do steps a) through e) in any order or combination that you like. The point is to reduce resource usage by Outpost, the plugins, and the logging system.

    Let us know how you progress after tying some of the ideas presented.

    Have a good day.
    Last edited by David; 11 Apr 2003 at 08:00.
    Kind Regards,


  9. #9
    Ross Guest
    Thanks for all the good advice. Things have come right after a reboot and disabling a couple of Outposts options, like Ad banners.

    I'm already using Winamp2 & Wintop. I'll keep the other suggestions in mind if I need them.


  10. #10
    racerxnet Guest


    The Via Chips had a latency problem. Via is well aware of this problem, and has a latency patch out as well as George Breese. The latency issues are really noticable when running the onboard raid controller and running Atto Disk Benchmarking. The patch is for specific chipsets, and information can be found on the web. Several sound cards are effected by this glitch with the PCI latency issue.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Audio stuttering while browsing
    By CrEsPo in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 25
    Last Post: 09 Mar 2012, 02:30
  2. [HELP] Outpost Pro with SRS HD Audio Lab
    By CocoNuts in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 0
    Last Post: 04 Mar 2011, 20:27
  3. Streaming Audio?
    By P220ST in forum Outpost Pro FIREWALL General Discussions, Support, and Troubleshooting
    Replies: 0
    Last Post: 04 Feb 2007, 02:12
  4. Old audio cd's to mp3
    By minoka in forum Computer Help
    Replies: 12
    Last Post: 26 Mar 2006, 22:59
  5. The best audio player just got better!
    By Lithp in forum Chit Chat
    Replies: 2
    Last Post: 29 Aug 2002, 18:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts